Solving Error After Updating WordPress 3.6


Are you using WordPress for your blog?

Have you updated your WordPress to 3.6 version?

There is some error in your post list, isn’ you?

Error message:

Warning: htmlspecialchars () [function.htmlspecialchars]: charset `UTF-7 ‘not supported, assuming iso-8859-1 in / home / halotekn / public_html / wp-includes / formatting.php on line 2751

Oke, be enjoy and don’t panic, guys!

check formatting.php file on public_html / wp-includes  in line 2751:

2750 – esc_textarea function ($ text) {
2751 – $ safe_text = htmlspecialchars ($ text, ENT_QUOTES, get_option (‘blog_charset’));
2752 – return apply_filters (‘esc_textarea’, $ safe_text, $ text);
}

And replace by:

2750 – esc_textarea function ($ text) {
2751 – $ safe_text = @htmlspecialchars ($ text, ENT_QUOTES, get_option (‘blog_charset’));
2752 – return apply_filters (‘esc_textarea’, $ safe_text, $ text);
}

You still add “@” before htmlspecialchars and your problems will solved!

Enjoy it!🙂

One thought on “Solving Error After Updating WordPress 3.6

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s